在Ubuntu下编译安装pgAdmin

  猛禽
  数据库
  2012-03-24
  增加更多TAG »
  7,007次

Ubuntu 10.04的apt里带的pgAdmin是1.10,只能连接pg8.4及以下,但是我要连一个服务器是9.1的,只好装个高版本。结果编译源码安装碰到些问题,google了英文资料也不多,自己试了几下解决的。记录一下:

OS: Ubuntu 10.04 LTS
pgAdmin: 1.14 source code

Install:

./configure
make
make install

Trouble shooting:

1. configure: error: Could not find your PostgreSQL installation. You might need to use the --with-pgsql=DIR configure option

apt-get install libpg-dev

2. configure: error: Could not find your wxWidgets installation. You might need to use the --with-wx=DIR configure option

apt-get install wx-common libwxgtk2.8-dev

3. configure: error: Could not find your libxml2 installation. You might need to use the --with-libxml2=DIR configure option

apt-get install libxml2-dev

4. configure: error: Could not find your libxslt installation. You might need to use the --with-libxslt=DIR configure option

apt-get install libxslt1-dev

5. ./db/keywords.c:33:27: error: parser/kwlist.h:...

apt-get install postgresql-server-dev-8.4

推送到[go4pro.org]


除非另有来自Go4Pro.org或原作者的显式声明,本站点所有文章都按照知识共享许可协议知识共享署名-非商业性使用-禁止演绎 3.0 未本地化版本许可协议进行许可。

Go4Pro.org,V3.0,2009-2014。本站点采用SymfonyBootstrapTwig等技术开发。